postplacehold

Di awal saya berniat untuk membuat template blog WapBlog.ID dengan batasan XHTML 1.1 dan CSS 2.1, khusus untuk mobile dan berhasil. Ini sederhana, kecil dan tidak memerlukan JavaScript. Walaupun demikian, situs hanya memiliki satu kolum, walaupun dibuat dua atau lebih column, tidak bisa akan responsive.

Mungkin saya akan tambahkan JavaScript sebagai sarana untuk transformasi responsive berbasis lebar web browser yang dibuka. Jadi hanya akan aktif bila browser melebihi lebar tertentu. Ini optimal, dan masih dalam proses.

XHTML 1.1 CSS 2.1 Blog Template akan tersedia di WapBlog.ID Store jika selesai.

Next... HTML5 dan khusus modern web browser, namun mendukung banyak web browser yaitu versi lawas Bootstrap 2.x. Ini bootstrap lawas dan versi terakhir update adalah 2.3.2 pada 27 Juli 2013 (hampir 8 tahun). Berbeda dengan Bootstrap 4.x dan Bootstrap 5.x terbaru, versi lawas punya komponen lebih sedikit dan itu cukup untuk suatu tanpa banyak User Interactive (UI) untuk memakainya.

Bootstrap 4.x dan ke bawah memerlukan JQuery untuk jalan. Versi JQuery yang digunakan oleh Bootstrap 2.x adalah JQuery 1.x.

WapBlog.ID blog storage mendukung file dengan extensi terbatas, dan .js untuk JavaScript file tidak didukung. Berikut adalah daftarnya:

Image: GIF, JPG/JPEG, PNG, ICO, WEBP, SVG
Audio: MID, AMR, WAV, AAC
Video: MP4, 3GP
Other: JAR, ZIP, RAR, SWF, TXT, PDF, APK, CSS

Ini membuat satu blog perlu untuk menyisipkan snippet script dari situs luar. Solusiny adalah menggunakan CDN dengan versi yang fix, sebagai berikut:

Dengan adanya external script, pemasangan template dimungkinkan bisa lebih cepat dikarenakan user tidak perlu mengunggah file tertentu ke blog yang dirujuk.